
Chapter 5
Getting Started with Docs

IN THIS CHAPTER
 Taking a good look around Docs
 Creating, saving, opening, and other document chores
 Navigating, selecting, deleting, and other editing basics
 Searching and replacing text
 Making sure your spelling and grammar pass muster

Google Docs is the G Suite app for word processing. Wait a minute:
word processing. Ugh. Personally, I've never liked the term. It sounds so
cold and so, well, computer-like. I mean, processing words? What the
heck does that mean? The bank processes checks, the Internal Revenue
Service processes tax returns. Who processes words? We write them,
play with them, misuse them, misspell them, forget them; but process
them? No.

But the computer geeks of the world decided long ago that that's what
digital writing should be called, so it looks like we're stuck with it. Okay,
but what is “it,” exactly? Well, in watch-their-eyes-glaze-over terms,
word processing is using a computer to write, edit, format, and print
documents. Yeah, I know, it doesn't sound glamorous, but it's not really
supposed to be. I mean, think about it: Most of the writing we do is grunt
work anyway: memos, letters, essays, diatribes, and harangues of one
sort or another. All we really need is to get the words down, dot the i's
and cross the t's, and make it presentable. Everything else — whether it's
putting together a newsletter or writing a report — is just an extension of
this basic stuff.

In this chapter, you learn how to process words with Google Docs. This
chapter offers a few Docs basics, and then you get into ever-so-slightly



more advanced topics in Chapters 6 and 7.

Opening Docs
Perform a few jumping jacks, head rolls, or other warm-up activities and
then, when you're good to go, use either of the following techniques to
get Docs on the stage:

Grab your web browser by the shoulders and gently point it toward
https://docs.google.com.

If you're in a G Suite app that has the Google Apps icon (such as
Mail or Calendar; see Figure 5-1), select Google Apps and then
Docs.

https://docs.google.com/


FIGURE 5-1: Choose Docs from the Google Apps menu.



Touring the Google Docs Home
Page

When you first land on Docs, you see the home page, which looks
pleasingly similar to the page shown in Figure 5-2.

FIGURE 5-2: The home page is your Docs starting point.

Let's take a quick trip around the screen so that you know what's what
here (refer to Figure 5-2, which points out the following features):



Main menu: An icon you click to open the main menu, which gives
you access to other G Suite apps (such as Sheets and Slides),
Settings, and Drive. To close the menu, click on any empty space
outside of the menu.
Search: Enables you to search Docs for the document you want.
Google apps: Displays icons for all Google apps.
Google account: Gives you access to your Google account.
Start a new document: Displays a few templates you can use to
start a new document. (A template is a document that comes with
predefined text, formatting, and even an image or three to get you off
to a good start.)
Template gallery: Displays the complete list of templates.
Recent documents: The three documents you've worked on most
recently.
Open File Picker: Displays the Open a File dialog box so that you
can open a file from Drive or from your computer.

Creating a Shiny, New Document
After you land on the Docs home page, you can open a file you worked
on previously (more on that later, in the section “Opening an existing
document”), but most of the time you'll want to create a new document.
You can ask Docs nicely in one of two ways to fire up a new document
for you:

To open an empty document (that is, a document with no
predefined text or formatting): In the Start a New Document
section, select the Blank template tile.
To open a document that has some ready-to-edit text and
formatting: Either choose one of the other template tiles shown in
the Start a New Document section or click Template Gallery and
then select a template from the long list of possibilities that Docs
displays.



Checking Out the Document Screen
Whether you create a new document or open an existing document, you
end up cheek-by-jowl with the document screen. Figure 5-3 shows an
example and points out the following features:

Toolbar: Offers one- or two-click access to the most popular Docs
features.
Docs home: Takes you back to the Docs home page.
Document name: The name you've given your document. When you
start a new document, the area is labeled Untitled Document.
Menu: Gives you access to the full arsenal of Docs commands,
features, and tools.
Save status: Lets you know (among other things) when the
document was last edited.



FIGURE 5-3: A typical document and the Docs features that surround it.

Hide menus: When selected, hides the Docs Home icon, the menu,
and the document name to gain a bit more vertical headroom for
your document.
Google account: Gives you access to your Google account.
Side panel: The term for the sidebar on the right, consisting of the
following elements:

Calendar: Opens the Calendar pane for quick access to your
Google Calendar



Keep: Opens the Keep pane so you can create a note to store
in the Keep app
Tasks: Opens the Tasks pane so you can create a task to store
in the Tasks app

Hide side panel: An arrow you click to collapse the side panel and
gain a little extra horizontal legroom. Click the arrow again to restore
the side panel.
Document area: Where you add, edit, and format your document
text.
Document outline: Displays the main headings of your document,
which gives you a bird's-eye view of the structure of your document.
You can also navigate your document by selecting the headings.
Close document outline: Hides the outline if you don't need it. To
get it back, click the Show Document Outline icon that replaces the
outline.

Dealing with Documents
As you might expect from its name, Docs is all about documents. So
before you learn how to add, edit, and format text, it pays to take a few
short moments (I promise) to learn some basic document chores.

Saving your work — just kidding!
One of the unexpected benefits you get with Docs is a better night's
sleep. Why? Because you'll no longer wake up at 3 A.m. wondering
whether you forgot to save the last document you were working on. Why
not? Because Docs saves all your work automatically. Add some text
and Docs saves it. Change the formatting and Docs save that, too. Docs
even saves changes to brand-new documents that you haven't even
named yet.

With each change you make as you work in Docs, the document's Save
Status text (pointed out earlier, in Figure 5-3) changes to Saving … as
shown in Figure 5-4. When the save is complete, you see the status All



changes saved in Drive, as pointed out in Figure 5-5. There's your
good night's sleep right there.

FIGURE 5-4: After you name your new document, Docs saves it for the first time.

FIGURE 5-5: When the save is complete, Docs lets you know that all is well.

Now you can relax because Docs takes over the saving duties from here.
Every time you make a change to the document, you see the saving
status change briefly to Saving, followed a second or two later by the
calm-inducing message All changes saved in Drive. Later, after you
close and then reopen the document, the status tells you how long ago
you last edited the document. (Refer to Figure 5-3 for an example.)

Naming a new document
If you've just started a new document, one of your earliest tasks should
be to give the document a descriptive name. Docs launches new
documents with the accurate but decidedly nondescriptive name Untitled
Document. No self-respecting document should walk around with that
moniker, so follow these steps to give your document a proper name:

1. Select the Untitled Document text, which appears near the top-
left corner of the page.
Alternatively, you can choose File ⇒   Rename.
Either way, Docs opens the filename for editing.

2. Delete the Untitled Document text.

3. Enter the name you want to use for the new document.
4. Press Enter or Return.

Docs saves the document by using the new name.



Opening an existing document
Some documents are one-shot deals. That is, you create the document,
name it, add text and formatting, and then you're done with the
document and it never sees the light of day again. A much more
common scenario is that you create the document, name it, add text and
formatting, work on something else for a while, and then return to the
original document and work on it some more.

To return to a document so that you can take another crack at it, you
need to open it by following these steps:

1. Open the Docs home page.
2. If you see the document you want to open in the Recent

Documents area, select it and then skip the rest of this procedure.
Otherwise, click Open File Picker (pointed out earlier, in Figure
5-2).
Docs displays the Open a File dialog box, shown in Figure 5-6.

FIGURE 5-6: Use the Open a File dialog box to choose which document you want
to work on.

3. Choose the document you want to mess with.



Note that Docs gives you several tabs to play with in the Open a File
dialog box. Here's what they mean:

My Drive: Select a document that's stored in your online
Drive.
Shared with Me: Select a document that someone else has
shared with you. To learn how this sharing thing works, see
Chapter 11.
Starred: Select from a list of Drive documents that you've
starred (meaning the documents are your favorites or are
special in some way). To star a document, surf to
https://drive.google.com, select the document, select
More Actions (the three vertical dots above the document
list), and then select Add to Starred.
Recent: Select from a list of Drive documents that you've
worked on in the last month.
Upload: Select a document by copying it from your computer
to Drive. You can either drag a document into the tab or you
can click the Select a File from Your Device button and then
… yes … select a file.

4. Click Open.
Docs opens the file, free of charge.

Saving a copy of a document
One of the secrets of Docs productivity is to never reinvent the wheel.
That is, if you have an existing document and you need a second
document that's similar, don't go to the time and trouble to re-create the
original document from scratch. Instead, it's not hard to convince Docs
to make a copy of the original. With that copy in hand, all you need to do
is make whatever changes are needed.

Here's how to make a copy of an existing document:

1. Open the document you want to copy.

https://drive.google.com/


2. Choose File ⇒   Make a Copy.
Docs opens the Copy Document dialog box. The Name text box
shows Copy of, followed by the name of the original document. (See
Figure 5-7 for an example.)

FIGURE 5-7: Use the Copy Document dialog box to clone an existing document.

3. Use the Name text box to give a descriptive name to the copy.
4. If you want to store the copy in a specific folder, click My Drive

in the Folder section, select the folder you want to use, and then
click Select.

5. Click OK.
Docs opens a new browser tab and displays the copy you just
created.

Learning Some Editing Basics



You almost certainly have better things to do than hang around all day in
Docs. To get your Docs duties out of the way so that you can move on to
more interesting or fun things, you need to learn a few editing basics that
will stand you in good stead throughout your Docs career. The next few
sections take you through a few pretty much painless keyboard-and-
mouse editing techniques.

Navigating with the keyboard
Docs has a fistful of ways to navigate your documents from the
keyboard. In this section, you'll work your way up from short hops
between characters and words to great leaps between screens and pages.

Navigating characters and words
The simplest move you can make in a document is to use the left- and
right-arrow keys to move left or right one character at a time. If you
have a bit of ground to cover, try holding down the arrow key. After a
slight delay, the cursor starts racing through each line. (Notice that when
it hits the end of one line, it starts over at the beginning of the next.)

If you need to jump over a couple of words, hold down the Ctrl key
(Option key on a Mac) and then use the left- or right-arrow keys to move
one word at a time.

 If you're in the middle of a long word, such as
hippopotomonstrosesquipedalian (which is a very, very long word
that means “pertaining to very, very long words”), press Ctrl+left
arrow (Option+left arrow on a Mac) to move quickly to the
beginning of the word.

Navigating lines and paragraphs
If you need to move up or down one line at a time, press the up- or
down-arrow key. If you're at the bottom of the screen and you press the
down arrow, the text moves up so that you can see the next line. (The
line that used to be at the top of the screen heads off into oblivion, but
don't worry: Docs keeps track of everything). A similar thing happens if



you're at the top of the screen (unless you're at the top of the document):
If you press the up arrow, the text moves down to make room for the
next line. Moving text up or down like this is called scrolling the
document.

To move to the beginning of the current line, press Home (⌘  +left arrow
on a Mac); to move to the end of the current line, press End (⌘  +right
arrow on a Mac).

 Some keyboards sneakily hide the Home and End keys inside
other keys (usually the left and right arrow keys). To “press” these
hidden keys, you need to hold down the Fn key. That is, to select
Home, press Fn+Home, and to select End, press Fn+End.

If you need to jump around a paragraph at a time, press Ctrl+up arrow
(to move up one paragraph; press Option+up arrow on a Mac) or
Ctrl+down arrow (to move down one paragraph; press Option+down
arrow on a Mac).

Navigating headings, screens, and documents
For really big documents, you need to know how to cover a lot of
ground in a hurry. Docs, of course, is up to the task.

With the cursor inside a heading, to move to the next heading, hold
down Ctrl+Alt (Control+⌘   on a Mac), press n (for next), and then press
h (for heading). To move to the previous heading, hold down Ctrl+Alt
(Control+⌘   on a Mac), press p (for previous), and then press h (for
heading).

 As you learn in Chapter 6, Docs has six levels of headings, from
Heading 1 through Heading 6. To navigate to the next heading level
x, make sure the cursor is inside a heading, hold down Ctrl+Alt
(Control+⌘   on a Mac), press n, and then press x (where x is a
number from 1 to 6). To navigate to the previous heading level x,



hold down Ctrl+Alt (Control+⌘   on a Mac), press p, and then press
x (where x is a number from 1 to 6).

To move down one screenful, press Page Down. To move up one
screenful, press Page Up.

 Some smaller keyboards bury the Page Up and Page Down keys
inside other keys (usually the up and down arrow keys). To “press”
these hidden keys, you need to hold down the Fn key. That is, to
select Page Up, press Fn+Page Up (Fn+up arrow on a Mac), and to
select Page Down, press Fn+Page Down (Fn+down arrow on a
Mac.).

For truly large leaps, press Ctrl+Home to move to the beginning of the
document (Fn+⌘  +left arrow on a Mac), or Ctrl+End to move to the end
of the document (Fn+⌘  +right arrow on a Mac).

Selecting text
Before you can do anything with text, you need to select it. Docs gives
you these main techniques:

Select a word: Double-click the word.
Select a line: Click at the beginning of the line, hold down Shift, and
then click at the end of the line.
Select a sentence: Click at the beginning of the sentence, hold down
Shift, and then click at the end of the sentence.
Select any text: Move the mouse pointer to the beginning of the
text, and then click-and-drag the mouse over the entire text
(including down if you need to select text on multiple lines).
Select a paragraph: Triple-click inside the paragraph.
Select text to the end of the paragraph: Press Shift+Ctrl+down
arrow.



Select text to the beginning of the paragraph: Press Shift+Ctrl+up
arrow.
Select everything: Press Ctrl+A.

Deleting stuff
I have the same trouble throwing things away when I'm writing. As my
editor will tell you, I have a hard time deleting anything. (I think I just
get too attached.) However, Docs isn’t at fault, because it gives you all
kinds of ways to nix troublesome text. This section shows you how.

I moved recently, and it only took me five minutes of packing to realize
something: I'm a hoarder. (I said hoarder.) I never throw anything away
— old gum wrappers; ticket stubs from every baseball, football, hockey,
and basketball game I've ever attended; an ancient (and British!?)
version of Monopoly. And books! Don't get me started with books!

 Before going on any kind of deletion rampage, you should know
that there's a section, later in this chapter, called “To err is human,
to undo divine.” If you wipe out anything you shouldn't have, read
ahead to that section to see how to make everything okay again.

Deleting characters
Did you spell potato with an e again? Or perhaps you've just seen the
Queen on TV and have been spelling words like colour and cheque.
Well, not to worry: Docs makes it easy to expunge individual characters.
You have two options:

Press the Delete key to delete the character to the right of the cursor.
Press the Backspace key (Forward Delete on a Mac, or
Fn+Delete if your Mac keyboard doesn't have a Forward Delete
key) to delete the character to the left of the cursor.

If you'd like to delete several characters in a row, hold down Delete or
Backspace until all the riffraff is eliminated. (Be careful, though: The



cursor really picks up speed if you hold it down for more than a second
or two.)

Deleting words
To handle any stray words that creep into your documents, Docs lets you
delete entire words with a single stroke. Again, you have two methods
you can use:

Place the cursor just in front of the word and then press Ctrl+Delete
(Option+Forward Delete on a Mac, or Fn+Option+Delete if your
Mac keyboard doesn't have a Forward Delete key).
Place the cursor just after the word and then press Ctrl+Backspace
(Option+Delete on a Mac).

For fine-tuned deleting, you can even delete portions of a word. Here's
how:

To delete from the cursor to the end of a word: Press Ctrl+Delete
(Option+Forward Delete on a Mac, or Fn+Option+Delete if your
Mac keyboard doesn't have a Forward Delete key).
To delete from the cursor to the beginning of a word: Press
Ctrl+Backspace (Option+Delete on a Mac).

 Here's how I remember whether to use Ctrl+Backspace or
Ctrl+Delete: the word end ends with d, so you use Ctrl+Delete to
delete to the end of a word; the word beginning begins with b, so
you use Ctrl+Backspace to delete to the beginning of a word.
Clearer? No? Well, I tried.

To err is human, to undo divine
Let's face facts: Everybody deletes stuff accidentally, and one day you'll
do it, too. It's one of those reality things (like nose hair and income
taxes) that you just can't avoid. The good people at Docs know this, and
the gurus in the programming department came up with a way to ease



the pain: the Undo command. This command, as its name implies,
miraculously reverses your most recent action, such as an errant
deletion. (Which, believe me, has saved my bacon on more than one
occasion.)

To undo your most recent action in Docs, use either of the following
techniques:

Click Undo on the toolbar.
Press Ctrl+Z.

Fooling around with special characters
Were you stumped the last time you wanted to write Dag Hammarskjöld,
because you didn't know how to produce one of those ö thingamajigs? I
thought so. Well, you'll be happy to know that your documents aren't
restricted to just the letters, numbers, and punctuation marks you can
eyeball on your keyboard. In fact, Docs comes with all kinds of built-in
characters that will supply you with not only an ö but also a whole
universe of weirdo symbols.

Here's how it works:

1. Position the cursor where you want to insert the symbol.
2. Choose Insert ⇒   Special Characters.

Docs opens the Insert Special Characters dialog box, shown in
Figure 5-8. You see an impressive array of arrow symbols by default,
but I show you how to find what you need (assuming it's not an
arrow) in step 3.

3. Locate the character you want to add. Docs gives you several
ways to do this:

Scroll through the displayed symbols until you locate the one
you want.
Use the list on the right (it's labeled Arrows, by default) to
choose the category for your character.



Use the Search box to enter a word or phrase that describes
the character (such as diaeresis or cedilla).
Use the Draw a Symbol Here box to, yes, draw a reasonable
facsimile of your character, as shown in Figure 5-9. You can
use the mouse or trackpad, but it's easier if you have a digital
pen or touchscreen. Either way, this is a cool feature.

FIGURE 5-8: Use the Insert Special Characters dialog box to add silly symbols to
your document.



FIGURE 5-9: Yep, you can draw the character you want and Docs locates it based
on your rendition.

4. Click the character.
If you're not sure whether a particular symbol is the one you want,
hover the mouse pointer over the character to see a larger version of
the character and its description. (Again, refer to Figure 5-9.)
Docs inserts the character into the document at the cursor position.

5. Click Close (X).

Stating your case: Uppercase versus lowercase
On most keyboards, the Caps Lock key is just above the Shift key. In the
heat of battle, you might end up hitting Caps Lock by mistake a few
times a day. The result: ANYTHING FROM A FEW WORDS TO A
FEW LINES APPEARS IN UPPERCASE! Fortunately, Docs can get
you off the hook easily with its case-conversion feature, which you can
invoke to change your letters back to all-lowercase. If needed, you can
also change your letters to all-uppercase versions, and you can convert
your text to title case, which converts only the initial letter in each word



to uppercase (to change, say, the curious case of benjamin button to The
Curious Case Of Benjamin Button).

To convert the case of some text, follow these steps:

1. Select the text you want to convert.
2. Choose Format ⇒   Text ⇒   Capitalization.
3. Choose the command you want: lower case, UPPER CASE, or

Title Case.
Docs coverts the text to the case you chose.

Adding links
Your documents live on the web, so it makes sense that they should
contain a link or two. These can be links to websites or links to other
Docs files. Whatever you need, here are the steps to follow in order to
insert a link:

1. Select the text you want to change into a link.
Actually, this step is optional. If you're creating a brand-new link,
jump ahead to Step 2.

2. Choose Insert ⇒   Link.
 Alternatively, press Ctrl+K (⌘  +K on a Mac) or click the Insert

Link button on the toolbar.
3. If you didn't select text in advance, enter the link text in the Text

box.
4. Enter (or paste) the link address in the Link text box.

Docs also displays a website related to your selected text as well as
one or two recent documents, so you can click the website or a
document if that's what you want to link to.

5. Click Apply.
Docs inserts the link.

Setting tab stops



Documents look much better if they're properly indented and if their
various parts line up nicely. The best way to do this is to use tabs instead
of spaces whenever you need to create some room in a line. Why? Well,
a single space can take up different amounts of room, depending on the
font and size of the characters you're using. So your document can end
up looking pretty ragged if you try to use spaces to indent your text.
Tabs, on the other hand, are fastidiously precise: Whenever you press the
Tab key, the insertion point moves ahead exactly to the next tab stop —
no more, no less.

Docs lets you set three kinds of tab stop:

Left: Text lines up with the tab on the left. These tab types are
represented by right-facing triangles on the ruler at the top of your
document.
Right: Text lines up with the tab on the right. The ruler shows these
tab types as left-facing triangles.
Center: Text is centered on the tab. These tab types are represented
by diamond shapes on the ruler.

To set tab stops, first make sure Docs is displaying the ruler by pulling
down the View menu and choosing the Show Ruler command. With that
done, you set a tab stop by clicking the ruler at the spot where you want
the stop to appear and then choosing from the menu that appears with
the command corresponding to the type of tab stop you want:

Add Left Tab Stop
Add Center Tab Stop
Add Right Tab Stop

With your tab stop set, position the cursor at the beginning of the text
you want to align with the tab stop, then press Tab.

Figure 5-10 shows a document with each type of tab stop set and some
text tabbed to each stop.



FIGURE 5-10: Some tab-stop examples.

Search and Ye Shall Replace
If you've ever found yourself lamenting a long-lost word adrift in some
humongous megadocument, the folks at Docs can sympathize (because it
has probably happened to them a time or two). In fact, they were even
kind enough to build a special Find feature into Docs to help you find
missing text. And that's not all: You can also use this feature to seek out
and replace every instance of one word with another. Sound like fun?
Well, okay, maybe not, but it is handy, so you might want to read this
section anyway.

Finding stuff
If you need to find a certain word or phrase in a short document, it's
usually easiest just to scroll the text. But if you're dealing with more than
a couple of pages, don't waste your time rummaging through the whole
file. Bring the Find feature onboard and let it do the searching for you:

1. Choose Edit ⇒   Find and Replace.
Docs unearths the Find and Replace dialog box.
If you feel like it, you can also display Find and Replace by pressing
Ctrl+H.

2. Use the Find text box to enter the text you want to locate.
Docs helpfully highlights all instances of the text, as shown in Figure
5-11. Docs also adds X of Y to the right of the text box, where X is
the number of the instance of your search text that is selected in the



document and Y is the total number of instances of the search text in
the document.

3. If the selected instance of the search text isn't the one you're
looking for, click either Next (to move forward) or Previous (to
move backward) to select other instances until you reach the one
you want.

4. When you're done, click Close (X).

FIGURE 5-11: Use the Find text box to tell Docs what you're looking for.

Some notes on searching
Searching for text is a relatively straightforward affair, but it wouldn't be
Docs if there weren't 5,000 other ways to confuse the heck out of us. To



makes things easier, here are a few plain-English notes that'll help you
get the most out of the Search feature:

For best results, keep your search text as short as possible. A
word or two is all you usually need. Trying to match long phrases or
even entire sentences can be a problem because you increase your
chances of misspelling a word or accidentally leaving a word out of
the search text. (For example, if you want to search for It's a
wonderful day in the neighborhood and you enter It is a wonderful
day in the neighborhood, Docs scoffs at your efforts because the
beginning of the two sentences don't match.) And besides, it just
takes longer to type a lengthy phrase or sentence.
If you're not sure how to spell a word, just use a piece of it. Docs
still finds egregious if you search for egre (although, efficient beast
that it is, it also finds words like regret and degree).
To find only words that begin with the search text, add a space
before the text. As you can tell from the last point, Docs happily
finds a chunk of text that sits in the middle of a word (such as the
egre in regret and degree).
You can match not only the letters but also whatever uppercase
and lowercase format you use. If you need to differentiate between,
say, Bobby (some guy) and bobby (as in a bobby pin or an English
bobby), select the Match Case check box in the Find and Replace
dialog box.

Finding-and-replacing stuff
If you do a lot of writing, one of the features you'll come to rely on the
most is find-and-replace. This means that Docs seeks out a particular bit
of text and then replaces it with something else. This may not seem like
a big deal for a word or two, but if you need to change a couple of dozen
instances of irregardless to regardless, it can be a real time-saver.

Searching and replacing is, as you might imagine, not all that different
from plain old searching. Here's how it works:



1. Choose Edit ⇒   Find and Replace (or press Ctrl+H).
Docs digs up the Find and Replace dialog box.

2. Use the Find text box to enter the text you want to locate.
3. Use the Replace With text box to enter the text you want to use

in place of what's in the Find box.
Docs selects the first instance of the Find text in the document.

4. If the selected instance of the Find text isn't the one you're
looking for, click either Next (to move forward) or Previous (to
move backward) to select other instances until you get to the one
you want.

5. Click Replace.
Docs replaces the selected instance with the Replace With text and
then selects the next instance.

6. Repeat Steps 4 and 5 until you've replaced all the instances you
want.
As an alternative to Steps 4–6, you can just click Replace All, which
performs the replacement for every instance in the document.

 Clicking Replace All sure seems like the easy way to get this
chore finished faster, but some caution is required. Take a second
(and even a third) look at your Find and Replace With text and try to
think of any ways a Replace All operation can go wrong. For
example, you might want to replace the word egret with the word
heron. That's your business, but know that if you run Replace All
willy-nilly, you might also change regret to rheron and allegretto to
allheronto.

7. When you're done, click Close (X).

Checking Spelling and Grammar



Words. Whether you're a logophile (a lover of words) or a logophobe
(one who has an aversion to words), you can't leave home without ’em.
Whether you suffer from logomania (the excessive use of words) or
logagraphia (the inability to express ideas in writing), you can't escape
’em. So far, I’ve offered ways to edit words and ways to find words, but
when it comes down to using words, well, you've been on your own.
That changes now because in this section you learn about Spelling and
Grammar Check, an off-the-scale useful tool that'll help you become
word-wise. Who knows? You might become a full-fledged logolept (a
word maniac).

Handling spelling slip-ups
Nothing can ruin the image of your finely crafted documents more than a
few spelling mistakes. In the old days, you could just shrug your
shoulders and mumble something about never being good at spelling.
With Docs, though, you have no excuses because the darn program
comes with a tool that checks your spelling attempts automatically. If
Docs finds something that isn't right, it lets you know and gives you a
chance to correct it. You can make the spell checker smarter by adding
your own words to its dictionary.

When Docs finds a spelling snafu, it points out the rogue word by
underlining it with a red squiggle. Click the underlined word and Docs
displays a banner like the one shown in Figure 5-12.



FIGURE 5-12: Docs underlines in red those words it thinks are spelling lapses.

You have a bunch of possible moves you can make from here:

To change the word: Select the correction that Docs suggests in the
banner.
To have Docs skip this error: Click Ignore (X).
To have Docs always make this correction automatically in the
future: Click More Options (the three vertical dots) and then select
Always Correct to “correction” (where correction is the suggested
correction).
To tell Docs that your word is correct and to have Docs add it to
its dictionary (and therefore never bug you about it again): Click
More Options (the three vertical dots) and then select Add
“original” to Dictionary (where original is the word as you spelled
it).



 The Docs spell checker is good, but it's not that good. In
particular, it doesn't flag words that are merely misused (as opposed
to misspelled). For example, Docs is perfectly happy with both
“we're going wrong” and “were going wrong,” because everything
is spelled correctly. For this grammatical stuff, see the next section.

Handling grammar gaffes
Grammar ranks right up there with root canal and tax audit on most
people's Top Ten Most Unpleasant Things list. And it's no wonder,
either: all those dangling participles, passive voices, and split infinitives.
One look at that stuff and the usual reaction is, “Yeah, well, split this!”

If, like me, you couldn't tell a copulative verb from a correlative
conjunction if your life depended on it, help is just around the corner.
Docs comes with a tool that checks your grammar for you. That's right:
This utility actually analyzes your document, phrase by phrase, sentence
by sentence, and tells you when things aren't right. It even tells you how
to fix the problem — and often can do it for you at the click of a mouse.
It's about as painless as grammar gets, and it's the subject of this section.

When Docs trips over a grammatical gotcha, it shames the offending
word or phrase by underlining it with a wavy blue line. Clicking the
underlined word or phrase displays a banner like the one shown in
Figure 5-13. You have two ways to proceed:

To fix the problem: Select the correction that Docs suggests in the
banner.
To have Docs bypass this error: Click Ignore (X).



FIGURE 5-13: Docs underlines in blue those words or phrases it thinks are grammatical
flubs.



Chapter 6
Looking Good: Formatting

Documents
IN THIS CHAPTER

 Playing around with fonts, type sizes, and other typographical
niceties

 Monkeying around with alignment, line spacing, indentation,
and more

 Taking advantage of styles
 Seeing what numbered and bulleted lists are all about
 Inserting photos and other images into your documents

“The least you can do is look respectable.” That's what my mother
always used to tell me when I was a kid. This advice holds up especially
well in these image-conscious times. If you don't look good up front (or
if your work doesn't look good), you'll often be written off without a
second thought.

When it comes to looking good — whether you're writing up a memo,
slicking up a report, or polishing your résumé — Docs gives you a
veritable cornucopia of formatting options. This chapter gives you the
skinny on these various options, including lots of hints about how best to
use them.

Making Your Characters Look Good
The first step on your road to looking good is the lowly character. I
know, I know — you want to try out some really big stuff, but don't
forget all that blather about the longest journey beginning with a single



step yadda-yadda. Besides, working with characters can make a big
difference. Why, just a little bit of bolding here, a couple of italics there,
throw in a font or two, and suddenly that humdrum, boring memo is
turned into a dynamic, exciting thing of beauty. People from all over will
be clamoring to read your stuff. You will be, in short, a star.

Getting familiar with fonts
Until now, you may not have given much thought to the individual
characters that make up your writings. After all, an a is an a, am I right?
Well, Docs will change all that. When you start working with different
fonts, you can see that not all a's are the same (or b's or c's, for that
matter).

Just what the heck is a font, anyway?
Fonts are to characters what architecture is to buildings. In architecture,
you look at certain features and patterns; if you can tell a geodesic dome
from a flying buttress, you can tell whether the building is Gothic or art
deco or whatever. Fonts, too, are distinguished by a set of unique design
characteristics. Specifically, there are four things to look for: the
typeface, the type style, the type size, and the type position.

Typeface
Any related set of letters, numbers, and other symbols has its own,
distinctive design, called the typeface. Typefaces, as you can see in
Figure 6-1, can be wildly different, depending on the shape and
thickness of characters, the spacing, and whatever the designer had for
breakfast that day.



FIGURE 6-1: Some typeface examples.

 Type nerds differentiate between a typeface and a font in a way
that's analogous to the difference between an architectural style and
an example of that style. For instance, French Gothic is an
architectural style, and the Notre-Dame Cathedral in Paris is an
example of that style. Similarly, Arial is a typeface, and 12-point,
bold Arial is a font. Happily, despite all this type geekery, in this
chapter (and indeed throughout this book), I use the terms typeface
and font interchangeably.

Typefaces come in three flavors:

Serif: These typefaces contain fine cross strokes — typographic
technoids call them feet — at the extremities of each character. These
subtle appendages give the typeface a traditional, classy look.



Georgia (refer to Figure 6-1) is a common example of a serif
typeface.
Sans serif: These typefaces lack these cross strokes. As a result,
serif typefaces usually have a cleaner, more modern look. (Check out
Arial earlier, in Figure 6-1.)
Decorative: These typefaces are usually special designs used to
convey a particular effect. For example, if your document really
needs a sophisticated look for a wine-and-cheese invitation or some
similarly swanky event, Corsiva (refer to Figure 6-1) is ideal.

You can also classify typefaces according to the space they allot for each
character. This is called the character spacing of a font, and it can take
one of two forms:

Monospaced: These fonts reserve the same amount of space for
each character. For example, look at the Courier New font, shown
earlier, in Figure 6-1. Notice that skinny letters, such as i and l, take
up as much space as wider letters, such as y and w. Though this
strategy is admirably egalitarian, these fonts tend to look like they
were produced with a typewriter. (In other words, they're ugly.)
Proportional: These fonts, such as Arial and Georgia in Figure 6-1,
allot space to each letter according to the width of the letter. So the
scrawny i and l take up only a small amount of horizontal space, and
wider loads such as y and w take up a larger amount of space.

Type style and size
The type style of a font usually refers to whether the characters are bold
or italic. Docs also lets you set character attributes, like underlining and
strikethrough. These styles are normally used to highlight or add
emphasis to words or phrases.

The type size measures how tall a font is. The standard unit of
measurement is the point, where an inch has 72 points. For example, the
individual letters in a 24-point font are twice as tall as those in a 12-point
font. (In case you're wondering, this book is printed in a 10-point font.)



 To be nerdily precise about it, type size is measured from the
highest point of a tall letter, such as f or h, to the lowest point of an
underhanging letter, such as g or y.

Using different character sizes and styles is an easy way to fool people
into thinking you're a competent professional. For example, you can
make titles and section headings stand out by using bold characters that
are larger than regular text. Italics are good for company names and
book titles, and you can also use it for emphasizing important words or
phrases.

Type position
Characters normally follow each other along each line, but you can also
format the relative position of characters to produce superscripts
(slightly higher than normal) or subscripts (slightly lower than normal),
as shown in Figure 6-2.



FIGURE 6-2: Docs lets you change the relative position of characters to produce
superscripts and subscripts.

Formatting with fonts
Okay, enough theory. Let's get down to business and see how you go
about selecting different fonts for your documents. To begin with, select
the block of text you want to format. You then choose the font
formatting using any one of the following three methods (depending on
your mood):

On the menu bar, select Format and then Text.
Press a shortcut key.
Click a toolbar button.

Table 6-1 shows the Text menu commands and their corresponding
shortcut keys that you can select.

TABLE 6-1 Font Formatting via Menu and Keyboard

Text Menu Command Windows Shortcut Key Mac Shortcut Key

Bold Ctrl+B ⌘  +B

Italic Ctrl+I ⌘  +I

Underline Ctrl+U ⌘  +U

Strikethrough Alt+Shift+5 ⌘  +Shift+x

Superscript Ctrl+. (period) ⌘  +. (period)

Subscript Ctrl+, (comma) ⌘  +, (comma)

Size, Increase Font Size Ctrl+Shift+. (period) ⌘  +Shift+. (period)

Size, Decrease Font Size Ctrl+Shift+, (comma) ⌘  +Shift+, (comma)

If you do a lot of work with fonts, you'll appreciate the push-button
convenience of the font-related buttons on the Docs toolbar. Table 6-2
shows you the available buttons for font-related chores.

TABLE 6-2 Font Formatting from the Toolbar



Toolbar
Button

Button
Name What It DoesToolbar

Button
Button
Name What It Does

Font Displays a list of typefaces

Font size Displays a list of font sizes

Bold Applies bold to the text

Italic Applies italics to the text

Underline Underlines the text

Text color Displays a color palette and then applies the color you select to
the text

Highlight
color

Displays a color palette and then applies the color you select to
the background of the text

 By default, Docs offers 30 or so typefaces for your text
formatting pleasure. However, Google (via its famous Google Fonts
service — check out fonts.google.com) is home to hundreds of
typefaces. If none of the default Docs typefaces speaks to your
inner designer, pull down the toolbar's Font menu and select More
Fonts. This scores you an immediate appointment with the Fonts
dialog box, shown in Figure 6-3. If you see a font that looks good,
click it to add it to the My Fonts list. When you're done, select OK.

https://fonts.google.com/


FIGURE 6-3: Use the Fonts dialog box to choose from hundreds of choices from Google
Fonts.

Avoiding the ransom note look
The downside to the easy-to-use font features in Docs is that they can
sometimes be too easy to use. Flush with your newfound knowledge,
you start throwing every font formatting option in sight at your
documents. This can turn even the most profound and well-written
documents into a real dog's breakfast. (It's known in the trade as the
ransom note look.) Here are some tips to avoid overdoing the formatting:

Never use more than a couple of fonts in a single document.
Anything more looks amateurish, and will only confuse the reader.
If you need to emphasize something, bold or italicize it in the same
font as the surrounding text. Avoid using underlining for emphasis.
Use larger sizes only for titles and headings.
Avoid bizarre decorative fonts for large sections of text. Most of
those suckers are hard on the eyes after a half dozen words or so.



Serif fonts are usually very readable, so they're a good choice for
long passages. The clean look of sans serif fonts makes them a good
choice for headlines and titles.

Copy text formatting by “painting” it
If you've gone to a lot of trouble to format some text and you want to use
the same formatting elsewhere, you don't have to start from scratch.
Docs has a marvelously useful tool called Paint Format that can transfer
formatting from one bit of text to another. Here's how it works:

1. Select the text that has the formatting you want to use elsewhere.

2.  Click the Paint Format button on the toolbar.
The mouse pointer sprouts an icon that looks like a paint roller.

3. Select the text you want to format.
If you're working with a single word, just click the word. Otherwise,
drag the pointer over the text you want to format.
Without splattering or dripping, Docs applies the formatting from the
text in Step 1 to the new text.

Making Your Lines and Paragraphs
Look Good

The previous section shows you how to format characters, so now I
bump things up a notch and look at formatting lines and paragraphs.
How will this help you look good onscreen? Well, all the character
formatting in the world doesn't do you much good if your lines are all
scrunched together, and if the various pieces of text aren't lined up like
boot camp recruits. Documents like these look cramped and uninviting,
and often get tossed in the old circular file without a second look. This
section can help you avoid this sorry fate.



Getting your text ducks in a row: Aligning
paragraphs
Aligning stuff is about getting your paragraphs dressed up so that they
look all prim and proper. Specifically, I'm talking about lining up the left
and right ends of your paragraph lines with respect to the left or right
margins — or both. (I talk about margins in detail in the next chapter,
but for now all you need to know is that the left margin is the blank
space to the left of your document text and the right margin is the blank
space to the right of your document text.)

Docs offers three alignment methods:

On the menu bar, select Format and then Align & Indent.
Press a shortcut key.
Click a toolbar button.

Table 6-3 shows the Align & Indent menu commands, their
corresponding shortcut keys, and the equivalent toolbar buttons for the
four Docs alignment options.

TABLE 6-3 Paragraph Alignment in Docs

Align &
Indent Menu
Command

Windows
Shortcut
Key

Mac
Shortcut
Key

Toolbar
Button What It Does

Left Ctrl+Shift+L ⌘  
+Shift+L Aligns each line on the left margin

Center Ctrl+Shift+E ⌘  
+Shift+E

Centers each line between the left
and right margins

Right Ctrl+Shift+R ⌘  
+Shift+R Aligns each line on the right margin

Justified Ctrl+Shift+J ⌘  
+Shift+J

Aligns each line on both the left and
right margins; ignores the last line in
a paragraph if it's too short



Before you select an alignment option, first tell Docs what you want to
format:

To format a single paragraph, click anywhere inside that paragraph.
To format multiple, consecutive paragraphs, select those paragraphs.
To format the entire document, pull down the Edit menu and choose
Select All, or press Ctrl+A (⌘  +A on a Mac).

With your selection made, select the menu command, toolbar button, or
shortcut key to apply the alignment. Figure 6-4 puts these alignment
commands through their paces.

FIGURE 6-4: Some paragraph alignment examples.

 Left-justified text is said to be ragged right because the right
ends of each line in the paragraph usually don't line up. Similarly,
right-justified text is called ragged left because the left ends of each
line in the paragraph don't line up.

Breathing room: Changing the line spacing



You can improve the look of your document's paragraphs by adjusting
the line spacing — the formatting tweak that determines the amount of
space between each line in the paragraph. For example, double spacing
leaves twice as much space between the lines as the standard single
spacing. Increasing the spacing creates more white space in the
document, which can make the document easier to read. However, don't
go overboard, because if you increase the line spacing too much, your
text can become harder to read because the lines are too far apart.

For example, Figure 6-5 shows the same text with three different line
spacing values:

The text on the left uses a line spacing of 0.6, and you can see that
the lines are far too close together to be read easily.
The text on the right uses a line spacing value of 2 (double spacing),
and you can see that the lines are too far apart for comfortable
reading.
The text in the middle uses a line spacing value of 1.15, and you can
see that the distance between each line is just right for reading.



FIGURE 6-5: Line spacing values that are too small (left), too large (right), and just right
(middle).

To set the line spacing, first specify what you want to format:

To format one paragraph, click anywhere within that paragraph.
To format multiple, consecutive paragraphs, select those paragraphs.
To format the entire document, pull down the Edit menu and choose
Select All, or press Ctrl+A (⌘  +A on a Mac).

 Now select the Format menu and then select Line Spacing, or click
the Line Spacing toolbar button. (If you don't see the Line Spacing
button, click the toolbar's More button — the three horizontal dots;
check out Figure 6-8.) You now have two choices:



Select a preset line spacing value: Single, 1.15, 1.5, or Double.
Select Custom Spacing to open the Custom Spacing dialog box,
shown in Figure 6-6. Enter a value in the Line Spacing text box and
then click Apply.

FIGURE 6-6: Use the Custom Spacing dialog box to set your own line spacing value.

Giving paragraphs some elbow room
There's a long-running debate in typographical circles about whether to
add space between paragraphs. Fortunately for you, the specifics of that
debate aren't important here, and I can offer the following advice:

If you indent the first line of your paragraphs (as I describe in the
later section “Indenting paragraphs”), you don't need space between
them.
If you don't indent, you need to add some space between paragraphs
so that it's always clear to the reader when one paragraph ends and
the next one begins.

To set the spacing between paragraphs, first specify what you want to
format:



To format one paragraph, click anywhere within that paragraph.
To format multiple, consecutive paragraphs, select those paragraphs.
To format the entire document, pull down the Edit menu and choose
Select All, or press Ctrl+A (⌘  +A on a Mac).

 Select the Format menu and then select Line Spacing, or click the
Line Spacing toolbar button. (If you don't see the Line Spacing button,
click the toolbar's More button — the three horizontal dots; refer to
Figure 6-8.) You now have three ways to go:

Select Add Space Before Paragraph to add a 10-point space before
each selected paragraph.
Select Add Space After Paragraph to add a 10-point space following
each selected paragraph.
Select Custom Spacing to open the Custom Spacing dialog box.
(Refer to Figure 6-6.) Enter a value, in points, in the Before or After
text box (or in both — why not?), and then select Apply.

Keeping stuff together
One way to jar your readers is to have what appear to be extraneous lines
just sitting there on the page. It might be a header at the bottom of a
page, an important paragraph broken across two pages, the last line of a
paragraph at the top of a page (known in the trade as a widow), or the
first line of a paragraph at the bottom of a page (known as an orphan).

 You can prevent these pathetic creatures from haunting your
documents by selecting the paragraph you want to format, selecting the
Format menu, and then selecting Line Spacing or clicking the Line
Spacing toolbar button. You can work with these three commands:

Keep with next: Ensures that the selected paragraph (such as a
heading) always appears on the same page as the paragraph that
follows it



Keep lines together: Ensures that all lines in the selected paragraph
appear on the same page
Prevent single lines: Ensures that the selected paragraph has no
widows or orphans

Indenting paragraphs
Indenting a paragraph means shifting some or all of the paragraph text
relative to the margins. Docs offers four paragraph indentation
possibilities:

Left: Shifts the entire paragraph away from the left margin by a
specified amount
Right: Shifts the entire paragraph away from the right margin by a
specified amount
First line: Shifts just the first line of the paragraph away from the
left margin by a specified amount
Hanging: Shifts all but the first line of the paragraph away from the
left margin by a specified amount

 The term hanging indents sounds weird, but they can be useful.
For example, hanging indents are often used for the items in a
bibliography and for dictionary entries.

To set the indentation, first specify what you want to work with:

To indent one paragraph, click anywhere within that paragraph.
To indent two or more consecutive paragraphs, select those
paragraphs.
To indent the entire document, pull down the Edit menu and choose
Select All, or press Ctrl+A (⌘  +A on a Mac)

Docs offers three left indentation methods:



On the menu bar, select Format and then Align & Indent.
Press a shortcut key.
Click a toolbar button.

Table 6-4 shows the Align & Indent menu commands, their
corresponding shortcut keys, and the equivalent toolbar buttons for the
two left indentation options in Docs. (If you don't see the Increase Indent
and Decrease Indent buttons, click the toolbar's More button — the three
horizontal dots; refer to Figure 6-8.)

TABLE 6-4 Left-Indent Paragraphs in Docs

Align & Indent
Menu
Command

Windows
Shortcut
Key

Mac
Shortcut
Key

Toolbar
Button What It Does

Increase indent Ctrl+] ⌘  +] Increases the left indentation of
the paragraph by half an inch.

Decrease indent Ctrl+[ ⌘  +[ Decreases the left indentation of
the paragraph by half an inch.

To set a custom indentation, follow these steps:

1. Choose Format ⇒   Align & Indent ⇒   Indentation Options.
Docs opens the Indentation Options dialog box, shown in Figure 6-7.

2. To set the left indentation, enter a value (in inches) in the Left
text box.

3. To set the right indentation, enter a value (in inches) in the Right
text box.

4. Use the Special Indent list to select either First Line or Hanging,
and then enter an indentation value (in inches) in the text box.

5. Click Apply.

You can also set the left, right, and first-line indents by using the ruler.
First, make sure the ruler is onscreen by pulling down the View menu
and selecting the Show Ruler command.



FIGURE 6-7: Use the Indentation Options dialog box to set up a custom indentation.

Using the ruler features pointed out in Figure 6-8, you can make the
following indent adjustments for the selected paragraph or paragraphs:

Click-and-drag the Left Indent marker to set the left indent.
Click-and-drag the Right Indent marker to set the right indent.
Click-and-drag the First Line Indent marker to set the first-line
indent.



FIGURE 6-8: You can set the left, right, and first-line indents by using the ruler.

Using Styles to Make Looking Good
Look Easy

As I hope I've shown so far in this chapter, formatting is essential if you
want to produce good-looking documents that get noticed. The problem
is that formatting always seems to take up so much time.

Suppose that you want to add a title to a document. Titles usually appear
in a larger, sans serif font, so you type in the text, select it, and then use
the Font and Font Size commands to set up the appropriate formatting.
For good measure, you also center the title. It looks not bad, but you
decide that the text needs to be bold. So you highlight the text again and
then apply the bolding. Things are looking good, but then you decide to
apply a larger type size. Once again, you highlight the text and then
make the size adjustment. After fiddling with a few more options
(maybe underlining or dark blue text would look good), you finally get
the title exactly right. You've just wasted ten minutes of your busy day,
but — hey, that's the reality of working with Docs, right?

Wrong. You don't have to stand for this! By learning how to use styles,
you can accomplish the same chore in ten seconds instead of ten
minutes. How is that possible? Well, you see, a style is nothing more
than a predefined collection of formatting and layout settings. Docs
comes with a few styles built-in, including a style named Title. This



means that rather than fuss around with formatting options, you can
instead just select the text you want to use as the title and then apply the
Title style. Docs immediately applies all the Title style's predefined
formatting options — just like that.

What if you don't like the default formatting of the Title style? That's not
a problem because it's also easy to define your own version of each
built-in style. For example, you can format some text with an 18-point,
bold, dark blue, Verdana font that's centered between the left and right
margins and then tell Docs to use that formatting instead of its default
formatting for the Title style. You'd then enter the document title, select
it, and apply the Title style. In the blink of an eye, Docs formats the text
as 18-point, bold, dark blue Verdana, centered between the left and right
margins. That's right: With a single command, Docs can throw any
number of character, line, or paragraph formatting options at the selected
text.

Style advantages
Here's a short list of just some of the benefits you gain when you use
styles:

The most obvious, of course, is the time you save. After you've
invested the initial few minutes to define your version of a style,
applying any style takes only a few mouse clicks.
You eliminate the trial-and-error that goes into many formatting
chores. After you've decided on a look that you like, you can capture
it in a style for all time.
If you change your mind, however, a style can be easily edited. Does
this mean that you have to go back and reapply the style throughout
the document? No way. Any text that’s formatted with that style is
automatically reformatted with the revised style. This feature alone is
worth the price of admission.
Styles make it easy to create documents that have a consistent look
and feel, because you can access your styles from any document.



Styles reduce the number of keystrokes and mouse clicks you need
to get the job done. In this age where repetitive strain injuries such as
carpal tunnel syndrome are reaching almost epidemic proportions,
anything that reduces the wear-and-tear on our sensitive anatomy is a
welcome relief.

If it all sounds too good to be true, well, there is a downside: Styles can
save you so much time that you may run out of things to do during the
day. (Pause while the laughter dies down.)

Applying default Docs styles to avoid reinventing
the style wheel
Before you go off in some kind of style-defining frenzy, you should first
check out the default Docs styles. The default styles (as opposed to the
custom versions of the styles that you create yourself) are built-in styles
that come with Docs. It has these nine default styles, listed here with
their keyboard shortcuts when they have one:

Normal text: This 11-point, black Arial font is used for regular
document text. Shortcut key: Ctrl+Alt+0.
Normal text (Ctrl+Alt+0; ⌘  +Option+0 on a Mac): This 11-point,
black Arial font is used for regular document text.
Title: This 26-point, black Arial font is ideal for document titles.
Subtitle: This 15-point, dark gray 3, Arial font is normally used for
document subtitles.
Heading 1 (Ctrl+Alt+1; ⌘  +Option+1 on a Mac): This 20-point,
black Arial font is used for first-level document headings.
Heading 2 (Ctrl+Alt+2; ⌘  +Option+2 on a Mac): This 16-point,
black Arial font is used for second-level document headings.
Heading 3 (Ctrl+Alt+3; ⌘  +Option+3 on a Mac): This 14-point,
dark gray 4 Arial font is used for third-level document headings.
Heading 4 (Ctrl+Alt+4; ⌘  +Option+4 on a Mac): This 12-point,
dark gray 3 Arial font is used for fourth-level document headings.



Heading 5 (Ctrl+Alt+5; ⌘  +Option+5 on a Mac): This 11-point,
dark gray 3 Arial font is used for fifth-level document headings.
Heading 6 (Ctrl+Alt+6; ⌘  +Option+6 on a Mac): This 11-point,
italic, dark gray 3 Arial font is used for sixth-level document
headings.

To apply these styles, first select the text you want to format. Docs then
gives you three choices:

Select the Styles list on the toolbar (see Figure 6-9) and then select
the style you want to apply. (Note that not all default styles appear in
this list. If you want to apply Heading 4 through Heading 6, you
need to use either of the methods that follow.)
Choose Format from the menu bar, select Paragraph Styles, choose
the style you want to apply, and then select Apply Style, where Style
is the name of the style.
Press the style's shortcut-key combo, which I’ve included in the
previous list.



FIGURE 6-9: The easiest way to apply most default styles is via the Styles list on the
toolbar.

Updating a default style to taste
Well, since fine words butter no parsnips, as they say (no, they really
do), let's get down to business and see how to define your own versions
of the default styles. The simplest way to go about this is to first format a
section of text exactly the way you want it. You can then update a



default style so that it uses your formatting instead of the predefined
Docs formatting. Here are the steps you need to follow:

1. Using some existing text, apply the formatting options you want
to include in the updated style.
You can use any of the formatting features I discuss in this chapter.

2. When you're done, make sure the cursor is inside the formatted
text.

3. Choose Format ⇒   Paragraph Styles, select the style you want to
update, and then choose Update Style to Match, where Style is
the name of the style.
Alternatively, select the Styles list on the toolbar, hover the mouse
pointer over the style you want to update, and then select Update
Style to Match, where Style is the name of the style.
Docs updates the style to match your formatting and also applies that
formatting to any other text in your document that currently uses the
same style.

 The new style only applies to the current document. If you want
to use the new style in other documents, you need to save the style,
and I talk about that in the next section.

Saving your updated styles
If you want to use an updated style only in the current document, that's
perfectly fine. However, you might find that you want to reuse one or
more of your updated styles in other documents. For example, if you've
updated some styles to match corporate formatting guidelines, you'll
want those updates available in every work document you create.

Docs is happy to comply, as long as you follow these instructions:

1. Follow the steps in the previous section to update the default
Docs styles as needed.



2. Choose Format ⇒   Paragraph Styles ⇒   Options ⇒   Save as My
Default Styles.
Alternatively, select the Styles list on the toolbar and then choose
Options ⇒   Save as My Default Styles.
Docs saves your updated styles.

Telling Docs to use your updated styles
If you find that a particular document isn't using your saved default
styles, you can give Docs a nudge in the ribs and tell it to use your
styles, by using either of these techniques:

Choose Format from the menu bar, select Paragraph Styles, choose
Options, and then select Use My Default Styles.
Pull down the toolbar's Styles list, choose Options, and then select
Use My Default Styles.

Resetting the default styles
If you make a mess of your style updates or if your style updates have
served their purpose and you no longer need them, you can reset all the
styles to their original Docs default formatting by using either of the
following techniques:

Choose Format from the menu bar, select Paragraph Styles, choose
Options, and then select Reset Styles.
Pull down the toolbar's Styles list, choose Options, and then select
Reset Styles.

Making Lists, Checking Them Twice
Are you making a list and checking it twice? Gonna find out who’s
naughty and — whoops, drifted off to the North Pole for a second! But if
you do want to include a list in your document, what’s the best way to go
about it? You can use separate paragraphs or headings that you number
yourself or add, say, asterisks (*) at the beginning. I suppose that would



work, but hold your list horses — there’s a better way. Docs has a couple
of commands that are specially designed to give you much more control
over your list-building chores.

Putting your affairs in order with numbered lists
If you want to include a numbered list of items — it might be a top-ten
list, bowling league standings, or any kind of ranking — don’t bother
adding in the numbers yourself. Instead, you can use the Numbered List
command in Docs to generate the numbers for you.

Before I get to the specifics, you should know that Docs is happy to
create multilevel numbered lists, where each level has its own
numbering format. Here's the default numbering format (see Figure 6-10
for an example):

The top level of the list uses regular numbers followed by periods
(1., 2., 3., and so on).
The second level of the list uses lowercase letters followed by
periods (a., b., c., and so on).
The third level of the list uses lowercase Roman numerals followed
by periods (i., ii., iii., and so on).



FIGURE 6-10: An example of a default, multilevel numbered list.

To forge a numbered list of your own, follow these steps:

1. If you have some existing text that you want to convert to a
numbered list, select that text.
Make sure that each “item” in your existing text is in its own
paragraph.

2. Choose Format ⇒   Bullets & Numbering ⇒   Numbered List.

 Alternatively, click the Numbered List button on the toolbar. (If
you don't see the Numbered List button, click the toolbar's More
button — the three horizontal dots; refer to Figure 6-8.)
Docs displays a menu of numbered-list formats, as shown in Figure
6-11.
For each format, Docs shows the numbering scheme that it uses for
the first, second, and third levels of the list.



FIGURE 6-11: Select Numbered List to see the available numbering schemes.

3. Select the numbering scheme you want to use.
If you selected some text in advance, Docs converts the text to a
numbered list. To add an item to that list, place the cursor at the end
of the last item and then press Enter or Return.

4. For a second-level item, press Tab; for a third-level item, press
Tab again.

5. Enter your item text and then press Enter or Return to create a
new item in the list.

6. Repeat Steps 4 and 5 until your list is complete.
7. Press Enter or Return a second time to tell Docs you don't want

to enter many more list items.

Scoring points with bulleted lists
Numbered lists, of course, aren’t the only kinds of lists. If you just want
to enumerate a few points, a bulleted list might be more your style.



They’re called bulleted lists because Docs displays a cute little dot,
called a bullet, to the left of each item.

Most bulleted lists are one level, but Docs doesn't mind creating lists that
have two or even three levels. Here's the default bullet format (see
Figure 6-12 for an example):

The top level of the list uses filled-in discs.
The second level of the list uses circles (that is, discs that aren't filled
in).
The third level of the list uses filled-in squares.

FIGURE 6-12: An example of a default, multilevel bulleted list.

To throw together a bulleted list, follow these steps:

1. If you have existing text that you want to convert to a bulleted
list, select that text.



For best results, each “item” in the text should be in its own
paragraph.

2. Choose Format ⇒   Bullets & Numbering ⇒   Bulleted List.

 As an alternative, you can click the toolbar's Bulleted List button.
(If you don't see the Bulleted List button, click the toolbar's More
button — the three horizontal dots; refer to Figure 6-8.)
Docs offers you a menu of bulleted list formats, as shown in Figure
6-13.
For each format, Docs shows the numbering scheme that it uses for
the first, second, and third levels of the list.

3. Choose the bullet scheme you want to use.
If you selected text in advance, Docs converts the text to a bulleted
list. To add an item to the list, place the cursor at the end of the last
item and then press Enter or Return.

4. For a second-level item, press Tab; for a third-level item, press
Tab again.

5. Enter your item text and then press Enter or Return to create a
new item in the list.

6. Repeat Steps 4 and 5 until your list is complete.
7. Press Enter or Return a second time to tell Docs you don't want

to enter any more list items.



FIGURE 6-13: Click Bulleted List to see the available bullet schemes.

Image Is Everything: Adding
Graphics

Television commercials assure us nowadays that “image is everything.”
And because they couldn't put it on TV if it weren't true (!), you need to
think about what kind of image your documents present to the outside
world. I've shown so far in this chapter how a few fonts and other
formatting options can do wonders for drab, lifeless text. But anybody
can do that kind of stuff. To make your documents stand out from the
crowd, you need to go graphical with images, photos, or other types of
eye candy. Happily, Docs has the tools that not only get the job done but
also make the whole thing a snap.

In fact, the image-related tools in Docs border on overkill because they
give you no fewer than a half dozen ways to insert an image into a
document:



Upload from computer: Inserts an image file that resides on your
PC
Search the web: Enables you to search for and then insert an image
from the web
Drive: Inserts an image file that's stored on your Google Drive
Photos: Inserts an image file that you've uploaded to Google Photos
By URL: Inserts an image file that resides at a specific web address
Camera: Inserts a photo taken via your computer's camera

In the next few sections, I walk you through the details of each method:

 Although I don't cover it in this book, Docs gives you a seventh
method to get graphics into a document: Select the Insert menu and
then choose Drawing. This opens the Drawing window, which you
can use to draw lines, arrows, shapes, and more. If you're an artist
(or an artist at heart), check it out.

 Okay, there's actually an eighth method for adding graphics to a
document. Select the Insert menu, choose Chart, and then choose a
chart type: Bar, Column, Line, or Pie. You can also select From
Sheets to import a Sheets chart, which is probably the best way to
go. (See Chapter 9 for the details on making charts with Sheets.)

Inserting an image from your PC
Probably the easiest way to get an image into a document is to insert a
file that resides on your computer. Here's how it's done:

1. Position the cursor at the spot where you want the image to
appear.

2. Chose Insert ⇒   Image ⇒   Upload from Computer.



 Alternatively, click the Insert Image toolbar button and then
choose Upload from Computer.
Docs displays the Open dialog box.

3. Select the image file you want to insert into your document.
4. Select Open.

Docs inserts the image.

Inserting an image from the web
If the image you want to use is on the web somewhere — and you have
permission to use that image — follow these steps to search for and
insert that image:

1. Place the cursor at the position where you want the image to
appear.

2. Chose Insert ⇒   Image ⇒   Search the Web.

 Alternatively, click the Insert Image toolbar button and then
choose Search the Web.
Docs displays the Search for Images pane.

3. In the Search for Images text box, enter some text that describes
the image you want and then press Enter or Return.
Google Images goes to work looking for images that match your
search text.

4. Select the image you want to use.
If you want to use multiple images, go for it: Select each image.

5. Click Insert.
Docs inserts the image (or images).

Inserting an image from Drive
If the image you want to use is stored on your Google Drive, you can
insert it from there. Here's how:



1. Place the cursor at the position where you want the image to
appear.

2. Chose Insert ⇒   Image ⇒   Drive.

 Alternatively, click the Insert Image toolbar button and then
choose Drive.
Docs displays the Google Drive pane.

3. Select the image you want to use.
If you want to use multiple images, don't let me stop you: Select each
image you want to insert.

4. Click Insert.
Docs inserts the image (or images).

Inserting an image from Photos
If the image you want to insert is one you've upload to Google Photos,
follow these steps to get the image from there to here:

1. Position the cursor where you want the image to appear and
then say “Stay!”

2. Choose Insert ⇒   Image ⇒   Photos.

 Alternatively, click the Insert Image toolbar button and then
choose Photos.
Docs displays the Google Photos pane.

3. Select the image you want to use.
To insert multiple images, select each image.

4. Click Insert.
Docs inserts the image (or images).

Inserting an image from a URL
If the image you want to use is on the web, and you happen to know the
address (also known as the URL — Uniform Resource Locator) of the
image, you can follow these steps to insert the image:



1. Use your web browser to copy the address of the image.
2. Maneuver the cursor into the position where you want the image

to show up.
3. Chose Insert ⇒   Image ⇒   By URL.

 Alternatively, click the Insert Image toolbar button and then
choose By URL.
Docs opens the Insert Image dialog box.

4. Paste the image address into the text box.
5. Select Insert.

Docs inserts the image.

Inserting a photo from your PC's camera
If your PC has a camera, you can persuade it to take a photo and then
shoehorn that image into your document. Here's how it works:

1. Get the cursor into the position where you want the photo to
appear.

2. Chose Insert ⇒   Image ⇒   Camera.

 Alternatively, click the Insert Image toolbar button and then
choose Camera.
The first time you do this, your web browser asks whether it's okay
for Docs to access your PC's camera, as shown in Figure 6-14.

FIGURE 6-14: Sensibly, Docs needs permission to use your computer's camera.

3. Select Allow.
Docs connects to the camera and displays a live feed.



4. Compose your shot as desired.
5. Select Insert.

Docs inserts the photo.

Setting a few image options
After you add an image to your document, you might need to make a
few adjustments, such as changing the size, color, or the way text flows
around the image. To make these and other tweaks, first select the image.
Docs adds a toolbar button named Image Options, which you can click
to see the Image Options pane, shown in Figure 6-15.

Here's a quick look at what you get with each category in the Image
Options pane:

Size & Rotation: Enables you to change the width and height of the
image or to scale the image larger or smaller. You can also rotate the
image.

 You can also resize the image directly by clicking-and-
dragging any of the square handles that appear on the image sides
and corners. You can rotate the image directly by clicking-and-
dragging the circle that appears above the selected image.
Text Wrapping: Determines how your document text interacts with
the image. Select Inline with Text to have the image appear on the
same line with the text that comes just before it; select Wrap Text to
have your document text flow around the image; or select Break Text
to have the document text stop before the image and then continue
after the image. If you go with Wrap Text or Break Text, you can use
the Margins from Text options to set the distance between the text
and the image.
Position: Determines how the image is positioned on the page. Note
that this category is enabled only if you select either Wrap Text or
Break Text in the Text Wrapping category.



Recolor: Enables you to apply a color effect to the image.
Adjustments: Offers sliders that enable you to adjust the image's
transparency, brightness, and contrast.

FIGURE 6-15: Select an image and then click Image Options on the toolbar to see the
Image Options pane.



Chapter 7
Fiddling with Document Layout
IN THIS CHAPTER

 Constructing sturdy tables for your Docs data
 Augmenting your documents with headers and footers
 Messing around with margins, breaks, and other page setup

chores
 Convincing text to display in columns
 Making footnotes look easy

In Chapter 6, I talk about Docs at the “tree” level of words, sentences,
and paragraphs. But getting more out of Docs also requires that you deal
with the app at the “forest” level of pages and documents. This means
you need to get familiar with the document layout and page setup tools.

The terms document layout and page setup refer to how text and
paragraphs are laid out on each page, and they involve building tables,
adding headers and footers, setting margin sizes, specifying the page
orientation, choosing the paper size, and so on. This chapter shows you
how to work with these and other document layout features.

Building a Table with Your Bare
Hands

In this section, you learn a bit of computer carpentry when I show you
how to build and work with tables. Don't worry, though, if you can't tell
a hammer from a hacksaw: The kinds of tables you deal with are purely
digital because, in Docs, a table is a rectangular grid of rows and



columns in a document. You can enter all kinds of info into a table,
including text, numbers, and graphics.

What is a table?
Most documents consist of text in the form of sentences and paragraphs.
However, you may find yourself in situations where you want to include
a list of items in a document and, if you want each item in the list to
include two or more details, a standard bulleted list won't do the job. For
a short list with just a few details, the quickest way to add the list to a
document is to type each item on its own line and press Tab between
each detail. You can then add tab stops to the ruler (see Chapter 6 for the
details on this topic) to line up the sub-items into columns.

That works for simple items, but to construct a more complex list in
Docs, you can build a table, a rectangular structure with the following
characteristics:

Each item in the list gets its own horizontal rectangle, called a row.
Each set of details in the list gets its own vertical rectangle, called a
column.
The rectangle formed by the intersection of a row and a column is
called a cell, and you use the table cells to hold the data.

In other words, a Docs table is similar to a Sheets spreadsheet. Figure 7-
1 shows a sample table.



FIGURE 7-1: A table in a Docs document.

Inserting a table
Here are the are-you-sure that's-all-there-is-to-it? steps to follow to insert
a table into a document:

1. Position the insertion point where you want the table to appear.
2. Choose Insert ⇒ Table.

Docs displays a grid of squares that you use to define the initial size
(that is, the number of rows and columns) of your table.

3. Move the mouse pointer over the square that corresponds to the
number of rows and columns you want in your table.
For example, to create a table with four columns and three rows,
move the mouse pointer over the square shown in Figure 7-2. Note
that the text below the grid says columns x rows, which tells you the
number of columns and rows in the current grid selection.



 If you need more squares for a big table, as you drag toward
the bottom and/or right, Docs expands the grid.

FIGURE 7-2: Use this grid to set the initial number of rows and columns in your
table.

4. Select the square.
Docs creates an empty table with the number of rows and columns
you specified. (See Figure 7-3, which appears a bit later in this
chapter.)

Populating a table
After you've created a table, your next task is to enter the table values.
As I mention earlier in this chapter, the intersection between each row
and column in a table is called a cell, and you use these cells to enter
text.

To try this out, either select the cell you want to work with or select any
cell and then use the following keyboard techniques to get around:

Press To Move

Tab Right one column

Shift+Tab Left one column

Up arrow Up one row

Down arrow Down one row



Now enter the value you want to appear in the cell. Here are some
guidelines to keep in mind:

If your text is longer than the width of the cell, Docs wraps the text
and adjusts the height of the cell to accommodate the entry.
You can format the cell text just like regular document text.
To start a new line within the cell, press Enter or Return.

FIGURE 7-3: You can set a column's width by dragging its Column marker on the ruler.

Adjusting column widths
By default, Docs creates each table with equal column widths. However,
chances are you'll want some columns narrower and some wider, so
make use of any of the following techniques to change the column
widths:

On the ruler, drag the Column markers (pointed out in Figure 7-3).
In the table, drag a column's right border.
In the Table Properties dialog box (see the next section), set the
Column Width value, in inches.

Selecting table cells



Whenever you need to work with one or more cells within a table, you
need to select those cells in advance. Here are the techniques to use:

Selecting a single cell: Click and drag the mouse pointer across the
width of that cell.
Selecting two or more cells in a table row: Move the mouse
pointer over the first cell you want to select, then click and drag the
pointer to the right until you've selected all the cells you need in the
row.
Selecting two or more cells in a table column: Move the mouse
pointer over the first cell you want to select, then click and drag the
pointer down until you've selected all the cells you need in the
column.
Selecting multiple cells in multiple rows and columns: Move the
mouse pointer over the first cell you want to select, then click and
drag the pointer down and to the right until you've selected all the
cells you need.
Selecting cells with the keyboard: Position the cursor anywhere
inside the first cell you want to select, then use the right and down
arrow keys to extend the selection to all the cells you need.

Setting table properties
To change the formatting of the table cells, you select the cells you want
to work with and then use the standard formatting tools (font, paragraph,
and so on). For more table-specific formatting, you can use the Table
Properties dialog box. Here are the steps to follow:

1. Select which part of the table you want to format:
To format just a cell, select that cell.
To format multiple cells, select those cells.
To format a column-related property, select one or more cells
in that column.



To format a row-related property, select one or more cells in
that row.

2. Choose Format ⇒ Table ⇒ Table Properties.
Docs offers up the Table Properties dialog box, shown in Figure 7-4.

3. Use the Table Border controls to set the color (left) and width
(right) of the table border.
If you want your table to be borderless, choose 0 pt for the border
width.

FIGURE 7-4: You can format various table settings in the Table Properties dialog
box.

4. Use the Cell Background Color palette to set the fill color for the
selected cell or cells.



5. Use the Cell Vertical Alignment option to set how the data in the
selected cell or cells is positioned vertically within its cell:

Top: Aligns the cell content vertically with the top edge of the
cell.
Middle: Aligns the cell content vertically with the middle of
the cell.
Bottom: Aligns the cell content vertically with the bottom
edge of the cell.

6. Select the Column Width check box and then enter a value, in
inches, in the text box to set the width of the selected column or
columns.

7. Select the Minimum Row Height check box and then enter a
value, in inches, in the text box to set the minimum height of the
selected row or rows.
Minimum height means that the row height can grow taller if needed
for the data, but it can't grow smaller than the value you specify.

8. Use the Cell Padding text box to set the value, in inches, of the
space that Docs adds around the data in the selected cell or cells.

9. Use the Table Alignment list to select how you want the data
aligned horizontally within the selected cell or cells.

Left: Aligns the cell content horizontally with the left edge of
the cell.
Center: Aligns the cell content horizontally with the center of
the cell.
Right: Aligns the cell content horizontally with the right edge
of the cell.

10. Use the Left Indent text box to set the value, in inches, that you
want Docs to indent the data in the selected cell or cells.
The Left Indent text box is enabled only if you select Left in the
Table Alignment list.

11. Click OK.



Docs puts the table properties into effect.

Inserting a new row or column
Unlike real carpentry, building a Docs table doesn't require all kinds of
advance planning (which is good news for those of us who wouldn't
know a blueprint from a blue moon). This is fortunate because, with
many of the tables you create, you won't know in advance how many
rows or columns you need. That's not a problem, though, because it's
easy enough to just create a basic table and then toss in a new row or
column whenever you need it. The following steps show you how it's
done:

1. Decide where you want the new row or column to appear and
then position the insertion point as follows:

If you're inserting a new row, position the insertion point in
any cell in a row that will be adjacent to the new row. If you're
adding a new row to the bottom of the table, use a cell in the
last row of the table.
If you're inserting a new column, position the insertion point
in any cell in a column that will be adjacent to the new
column. If you're adding a new column to the right of the
table, use a cell in the rightmost column of the table.

 If you want to insert multiple rows, you can insert them all in
one operation by selecting cells in the same number of existing rows.
For example, if you want to insert three rows into your table, select
cells in three existing rows. Again, you're inserting the new rows
either above or below the selection, so select the cells accordingly.
Yep, you can do this with columns, too, by selecting cells in the same
number of columns as you want to insert. For example, to insert two
columns into your table, select cells in two existing columns.

2. Choose Format ⇒ Table.



3. Choose the command you want to run:
Insert Row Above: Inserts a new row over the current row
Insert Row Below: Inserts a new row under the current row
Insert Column Left: Inserts a new column to the left of the
current column
Insert Column Right: Inserts a new column to the right of the
current column

 Need to add a new row to the bottom of a table? Here's the easy
way: Position the insertion point in the rightmost cell of the bottom
row and then press Tab. Don't mention it.

Deleting a row or column
If you end up with an extraneous column or row in your table, you
should remove it to keep things neat and tidy. Here's how:

1. Select at least one cell in the row or column you want to remove.
2. Choose Format ⇒ Table.
3. Choose the command you want to run:

Delete Row: Deletes the current row
Delete Column: Deletes the current column
Delete Table: Nukes the entire table — no questions asked

Merging table cells
Although most people use tables to store lists of data, using a table to lay
out a page in a particular way is also common. For example, if you’re
building a Docs document that looks like an existing paper form or
invoice, you almost certainly need to use a table to do it. However, on
most forms, not all the fields — which are the cells in the table you
create — are the same width: You might have a small field for a person's



age or a much wider field for an address, for example. Changing the
column width as I describe earlier doesn't work, because you need to
change the sizes of individual cells.

The best way to control how table data is laid out is to build your table
normally and then merge two or more cells. For example, if you merge
two cells that are side by side in the same row, you end up with a single
cell that’s twice the width of the other cells.

To merge cells, follow these steps:

1. Select the cells you want to merge.
You can select cells in a single row, a single column, or in multiple
rows and columns. However, the selection must be a rectangle of
adjacent cells.)

2. Choose Format ⇒ Table ⇒ Merge Cells.
Docs merges the selected cells.

Headers and Footers from Head to
Toe

A header is a section that appears at the top of each page between the
top margin and the first line of text. Any text, graphics, or properties you
insert in any header appear at the top of every page in the document.
Typical header contents include the document title and the date the
document was created or modified.

A footer is a section that appears at the bottom of each page between the
bottom margin and the last line of text. As with a header, anything you
insert in any footer appears at the bottom of every page in the document.
Typical footer contents include the page number and document filename.

 It's more precise to say that anything you insert in a typical
header or footer appears on every page of your document. A bit



later in this section, I show you how to set up different headers and
footers for the first page of the document and for odd and even
pages.

Here are your choices for adding content to a header or footer:

Text: You can type any text, such as a brief document description, a
note to the reader, your company name, or a link to a website or
another document.
Page numbers: You can insert just the page number, just the page
count (that is, the total number of pages in the document), or both.
For the last option, you probably want to insert something like the
phrase Page X of Y (where X is the current page number and Y is the
page count).
Image or drawing: You can insert a photo or another image using
any of the Docs image options, or you can draw something.

Adding a header
Here are the steps you need to plow through to add a header to your
document:

1. Choose Insert ⇒ Headers and Footers ⇒ Header.
You can also insert a header by holding down the Ctrl+Alt key
combo (on a Mac, hold down Ctrl+⌘  ), pressing O, and then
pressing H.
Docs opens the Header section, as shown in Figure 7-5.

FIGURE 7-5: Running the Header command opens the Header section for editing.



2. If you want to include page numbers in your header, choose
Options ⇒ Page Numbers.
Docs opens the Page Numbers dialog box, shown in Figure 7-6. Here
are some notes:

Leave the Header option selected.
If you don't want the page number to appear on the first page
(this is common), deselect the Show On First Page check box.
If you want your page numbers to start with a particular value,
enter that value in the Start At text box.

FIGURE 7-6: Use the Page Numbers dialog box to set up page numbers for your
header.

3. Click Apply to add the page numbers to the header.
4. To add the page count to the header, position the cursor where

you want the count to appear, and then choose Insert ⇒ Page
Numbers ⇒ Page Count.

5. To add more stuff to the header, position the insertion point
within the header and then enter some text, insert an image, or



whatever.
6. To close the header, click anywhere in the document.

Adding a footer
Here are the steps to follow to set up your document with a footer:

1. Choose Insert ⇒ Headers and Footers ⇒ Footer.
Another way to insert a footer is by holding down the Ctrl+Alt key
combo (on a Mac, hold down Ctrl+⌘  ), pressing O, and then
pressing F.
Docs opens the Footer section, as shown in Figure 7-7.

FIGURE 7-7: Running the Footer command opens the Footer section.

2. To add page numbers to your footer, choose Options ⇒ Page
Numbers.
Docs opens the Page Numbers dialog box. Here are a few things to
bear in mind:

Leave the Footer option selected.
To leave the page number off the first page, deselect the Show
On First Page check box.
If you want your page numbers to start with a value other than
1, enter that value in the Start At text box.

3. Click Apply to add the page numbers to the footer.
4. To add the page count to the footer, position the cursor where

you want the count to appear, and then choose Insert ⇒ Page
Numbers ⇒ Page Count.

5. To add more info to the footer, position the insertion point within
the footer and then enter some text, insert images, and so on.



6. To close the footer, click anywhere in the document.

Opening the header or footer for editing
After you close your header or footer, later you might decide to make
some changes to the existing text, add some new content, or whatever.
To make any changes to a header or footer, you have to open it. Here's
how:

Opening the header: Either double-click inside the header or hold
down the Ctrl+Alt key combo (on a Mac, hold down Ctrl+⌘  ), press
O, and then press H.
Opening the footer: Either double-click inside the footer or hold
down the Ctrl+Alt key combo (on a Mac, hold down Ctrl+⌘  ), press
O, and then press F.

Creating a unique first-page header and footer
By default, when you define the content for one header or footer, Docs
displays the same content in every header or footer in the document.
However, many situations arise in which this default behavior isn’t what
you want. One common situation is when you want to use a different
header or footer on the first page of a document. For example, many
texts use no header or footer on the first page. Another example is when
you want to insert document instructions or notes in the first header or
footer but you don't want that text repeated on every page.

For these kinds of situations, you can tell Docs that you want the first
page's header or footer to be different from the headers or footers in the
rest of the document:

Header: Open the Header section and select the Different First Page
check box. Docs changes the label of the first page header to First
Page Header.
Footer: Open the Footer section and select the Different First Page
check box. Docs changes the label of the first page footer to First
Page Footer.



Creating unique odd and even page headers and
footers
Many documents require different layouts for the header or footer on
odd and even pages. A good example is the book you’re holding. Notice
that the even page footer has the page number on the far left, followed
by the part number and title, whereas the odd page footer has the current
chapter number and title, followed by the page number on the far right.

To handle this type of situation, you can configure your document with
different odd and even page headers or footers by following these steps:

1. Choose Format ⇒ Headers & Footer ⇒ More Options.
Alternatively, either open the Header section for editing and then
choose Options ⇒ Header Format, or open the Footer section for
editing and then choose Options ⇒ Footer Format.
Either way, the Headers & Footers dialog box pops up.

2. Select the Different Odd & Even check box, as shown in Figure
7-8.



FIGURE 7-8: Select Different Odd & Even to work with unique odd and even page
headers and footers.

3. Click Apply.
Docs changes the labels of the page headers to Even Page Header
and Odd Page Header, and the labels of the page footer to Even Page
Footer and Odd Page Footer.

4. Open the Even Page Footer and add or edit the content you want
to see on your document's even-numbered pages.

5. Open the Odd Page Footer and add or edit the content you want
to see on your document's odd-numbered pages.

Changing the Page Setup
The Docs options and features for setting up pages are legion, but few
people use them with any regularity. That's a shame because the Docs
page setup tools are often useful and easy to use, after you get to know



them. In the next few sections, I walk you through the most useful of the
Docs page setup features.

Setting the page margins
One of the most common page layout changes is to adjust the margins,
or the blank space to the left and right, as well as above and below the
document text (including the header and footer). The standard margins
are 1 inch on all sides, but you can override that, if you like. Why would
you want to do such a thing? Here are a few good reasons:

If someone else will be making notes on the page, it helps to include
bigger left and right margins (to give the person more room for
scribbling).
Smaller margins all around mean that you can fit more text on a
page. On a really long document, this could save you a few pages
when you print it out.
If you have a document that's just slightly longer than a page (say, by
only a couple of lines), you can decrease the top and bottom margins
just enough to fit the wayward lines onto a single page.

Note, however, that decreasing the margins can make the page look
cluttered and uninviting. If you increase the margins, you fit less text on
each page, though the added white space can make the document look
more appealing.

You can set specific margin sizes for the top, bottom, left, and right
margins by following these steps:

1. Choose File ⇒ Page Setup.
Docs asks the Page Setup dialog box to make an appearance. (See
Figure 7-9.)

2. Use the Top text box to set the top margin.
3. Use the Bottom text box to set the bottom margin.
4. Use the Left text box to set the left margin.
5. Use the Right text box to set the right margin.



6. Click Apply.
Docs applies the new margin settings.

FIGURE 7-9: Use the Page Setup dialog box to set margin sizes.

You can also use the Docs ruler to adjust the left and right margins. First,
make sure the ruler is onscreen by choosing View ⇒ Show Ruler from
the menu bar. Look closely, and you see that the ruler has a mostly white
background, but it also has a gray background on the left and right sides.
These gray backgrounds contain two important controls called margin
markers:

Left Margin marker: This is the portion of the gray background on
the left side that runs from the right edge of the gray background to
the left edge of the page, as pointed out in Figure 7-10.
Right Margin marker: This is the portion of the gray background
on the right side that runs from the left edge of the gray background
to the right edge of the page, as pointed out in Figure 7-10.



FIGURE 7-10: Drag the margin markers to adjust the left and right margins.

Here how you use these margin markers:

To adjust the left margin, drag the Left Margin marker. Dragging left
decreases the margin, and dragging right increases the margin.
To adjust the right margin, drag the Right Margin marker. Dragging
right decreases the margin, and dragging left increases the margin.

Changing the page orientation
By default, page text runs across the short side of the page and down the
long side. This is called the portrait orientation. Alternatively, you can
configure the text to run across the long side of the page and down the
short side, which is called landscape orientation.

What's the use? You'd use the landscape orientation mostly when you
have text or an image that's too wide to fit across the page in portrait
orientation. If you're using letter-size paper and its margins are set to
0.75 inches, you have only 7 inches of usable space across the page.
Wide images, a table with many columns, or a long line of programming
code are just a few of the situations in which this width might not be
enough. If you switch to landscape, however, the usable space grows to
9.5 inches, a substantial increase.

Here's what you do to choose a page orientation:

1. Choose File ⇒ Page Setup.
Docs opens the Page Setup dialog box. (Refer to Figure 7-9.)

2. In the Orientation section, choose either Portrait or Landscape.
3. Click Apply.

Docs changes the orientation without protest.



Changing the paper size
Docs assumes that you'll be viewing or printing your documents on
standard letter-size paper, which is 8.5 inches by 11 inches. If you plan
to use a different paper size, you need to let Docs know so that it can
print the document correctly:

1. Choose File ⇒ Page Setup.
Docs opens the Page Setup dialog box. (Refer to Figure 7-9.)

2. In the Paper Size list, choose the size you want to use.
For example, for letter-size paper, choose Letter (8.5" x 11"). Two
other possibilities are Legal (8.5" x 14") and A4 (8.27" x 11.69").

3. Click Apply.
Docs changes the document's paper size — no problem.

Adding a page break
As you might know by now, Docs signals the start of a new page by
displaying a narrow gap between the previous page and the current page.
That gap is called a page break. Text that appears above the break prints
on one page, and text below the break prints on the next page. This text
arrangement isn’t set in stone, of course. If you insert a new paragraph or
change the margins, the text on both sides of the page break line moves
accordingly.

But what if you have a heading or paragraph that has to appear at the top
of a page? You can fiddle around by, say, pressing Enter above the text
until the text appears at the top of the next page, but that's a strategy that
too fragile to be useful.

Instead, Docs gives you an easier and more robust method. Position the
cursor at the start of the text that you want to appear at the top of a new
page, and then do either of the following:

Choose Insert ⇒ Break ⇒ Page Break from the menu bar.
Press Ctrl+Enter (⌘  +Enter on a Mac).



Docs creates a new page break at the cursor position.

Adding a section break
In Docs-related training sessions and question-and-answer periods, some
of the most common complaints and queries center on using multiple
page layouts in a single document:

How can I have different headers (or footers) for different parts of a
document?
I have a long table on one page. How can I set up that one page with
smaller margins?

Most people end up splitting a single document into multiple documents
to accomplish these and similar tasks. However, you don’t have to break
up your document just because you want to break up the page layout.
The secret to doing this is the section, a document part that stores page
layout options such as headers, footers, and margins.

When you create a document, Docs gives it a single section that
comprises the entire document. However, you’re free to create multiple
sections within a single document, and you can then apply separate page
layout formatting to each section. The transition from one section to
another is called a section break.

Docs offers two types of section breaks:

Next Page: Starts a new section on a new page
Continuous: Starts a new section at the insertion point (doesn’t add
a page break)

Follow these steps to add a section break:

1. Position the cursor where you want the new section to begin.
2. Choose Insert ⇒ Break.
3. Choose a section break:



Choose Section Break (Next Page) for a next-page section
break.
Choose Section Break (Continuous) for a continuous section
break.

Figure 7-11 shows what the Page Setup dialog box (choose File and then
Page Setup) looks like when you have one or more sections on the go.
You use the Apply To list to select the section you want to work with
(you can also choose Whole Document to work with everything), and
then make your margin adjustments for that section.

FIGURE 7-11: The layout of the Page Setup dialog box changes when you add a section.



Working with Columns, Just Like
the Pros

Docs, of course, is good for more than just the odd letter or memo. All
kinds of people are using the program to self-publish things like
newsletters, booklets, pamphlets, fanzines, and more. To give these
kinds of documents a more professional look, Docs lets you arrange text
into columns, just like you see in newspapers and magazines. (Check out
Figure 7-12 for an example.) The next few sections show you how to
define columns and enter text into them.



FIGURE 7-12: A document with text finagled into two columns.

Getting text into columns, Part 1: The easy way
Columns have always been one of those features that many people
avoided like the plague because, well, they just seemed too complicated
and so weren't worth the bother. Docs has changed all that, however, and
it's now easier than ever to set up and use columns. To prove it for
yourself, just follow these three oh-so-simple steps to define columns for
your document:

1. Select the text that you want to convert into columns.



If you want to convert the entire document, don't select anything.
If you haven't entered the document text yet, that's okay; it's
perfectly acceptable to set up columns first and then type the text
later.

2. Choose Format ⇒ Columns.
Docs displays the column options shown in Figure 7-13.

3. Choose either two columns (the middle option) or three columns
(the option on the right).
Docs converts your text into columns, just like that.

FIGURE 7-13: Select the Columns command, and then choose how many columns you
want.

Getting text into columns, Part 2: The ever-so-
slightly-harder way
Docs has a second column-creation method that gives you slightly more
control over the process. Here's how it works:



1. Select the text that you want to see in columns.
Don't select anything if you're looking to convert the entire
document to columns.

2. Choose Format ⇒ Columns ⇒ More Options.
Docs releases the Column Options dialog box, shown in Figure 7-14.

3. Use the Number of Columns list to select how many columns you
want.

4. Use the Spacing text box to set the distance, in inches, that you
want between each column.

5. If you want Docs to add a vertical line between each column,
select the Line Between Columns check box.
If you're using a somewhat narrow space between your columns (say,
anything less than half an inch), adding the line between columns
can make your text easier for folks to read.

6. Click Apply.
Docs wastes no time in converting your text into columns.

FIGURE 7-14: The Column Options dialog box gives you a few extra column-related
settings to fiddle with.

Entering text in columns



After you have defined your columns, your next step is to fill them in by
entering some text (unless, of course, you converted existing text into
columns). Here are some guidelines to follow when entering text in
columns:

Entering text in a column isn't all that different from entering text in
a normal document. Place the cursor into the column you want to use
and then start pecking away. If the columns are empty, you have to
begin at the top of the first column.
If you want to move the cursor to the next column before you reach
the end of the page (this is called inserting a column break), choose
Insert ⇒ Break ⇒ Column Break from the menu bar.

Show Your Work: Adding Footnotes
One of the best ways to make people think you worked really hard on a
document is to include footnotes at the bottom of the page. Footnotes
say, “Hey, this person took the time and effort to write this little
parenthetical note for my edification or amusement. I think I'll take them
out to lunch.”

To make sure we're on the same page (so to speak), here are some
concepts to keep in mind as you work through this section:

A footnote is a short note at the bottom of a page that usually
contains asides or comments that embellish something in the regular
document text on that page.
Docs indicates a footnote with a reference mark, a number that
appears as a superscript in both the regular text and in a special
footnote area at the bottom of the page.
Footnotes are a convenient way to add extra info for the reader,
though too many on one page can make your text look cluttered.

If you've ever tried adding footnotes to a page manually, you know what
a nightmare it can be trying to coordinate the size of the note with the



regular page text. And if you need to change your footnote numbers?
Forget about it.

Docs changes all that by making footnotes as easy as entering text. The
program arranges things so that your pages accommodate any footnote
size perfectly, and it even manages the footnote numbers for you —
automatically!

Because a footnote always refers to something in the regular text, your
first task is to position the insertion point where you want the little
footnote number to appear. (Usually, it’s at the end of whatever word,
phrase, or sentence your footnote is embellishing.)

After you've done that, choose Insert ⇒ Footnote from the menu bar.
(You can also press Ctrl+Alt+F or, on a Mac, ⌘  +Option+F.) Docs adds
a footnote number at the cursor, creates a special footnote area at the
bottom of the page, and then inserts the same footnote number there.
Now type your footnote text in the footnote area and you're done. Figure
7-15 shows an example.

FIGURE 7-15: A document with a footnote.


